The Filesystem

You will interact with the GoPlanogram filesystem any time you save, open, or import a planogram. All of these functions have convenience buttons in the command bar, or can be accessed from the File menu.

The filesystem consists of Planograms, which are your saved displays and floorplans, and Folders, which contain your files. If you do not have a GoPlanogram Pro subscription, only one level of folder is allowed. GoPlanogram Pro users may have infinite folder levels to support robust organization.

Filesystem View

If you don't want to deal with folder hierarchy (perhaps if you're searching for a particular file and don't know where it lives), there's always a tab in the left panel called All Planograms, which displays all planograms you own (in the case of an open operation), or all shared planograms on your site (in the case of an import operation).

Any time you are in the filesystem, as long as you own a file or folder, you may delete it, rename it, or reparent it to a different folder. To delete or rename a file or folder, Right-Click -> Delete / Rename. To reparent, Right-Click -> Move, navigate to the folder you want to move the selected file or folder to, then click Move.

Any time you are in the filesystem within a directory you own, you may create a new folder at that directoy by via Right-Click -> New Folder.

Saving

When you go to save your work for the first time, or click File -> Save As, you will see this dialog:

  1. Name: The name for your planogram. Maximum of 100 characters.
  2. Description: An optional description for your planogram. Maximum of 150 characters.
  3. Tags: These will only appear if you have a GoPlanogram Pro subscription. Select tag values from the dropdowns to apply to your planogram. Tags help you and other users of your organization filter through large sets of planograms.
    Tag names and values are set up by your site admin(s), and are completely customizable.
  4. Share Switch: Whether or not this planogram will be shared with all users on your site. If checked, other users will be able to import a copy of this planogram. You will always be the only one able to edit the original.
  5. Save Path: Displays the full save path for this planogram (the folder path, then the name of the planogram). If you want to change where this planogram will be saved, click the Change button, then navigate to the folder you want to save to.
  6. Save / Cancel: Pressing the Save button will attempt to save your planogram to the chosen file path. If a planogram with the same name exists at that path, you will be prompted to overwrite the old file.
    Pressing Cancel will close the save dialog, without saving anything.

Opening

Opening a planogram is the act of loading one of your own saved planograms (as opposed to import, which allows for you to load or insert anyone else's shared planograms, as well as your own).

To open a planogram, click on the one you want from the filesystem, then click the Open button. The Open Planogram dialog contains many controls to help you find the planogram you're looking for.

  1. Main Searchbar: Search the current folder for a Planogram or Folder that matches some input.
    Like searching the catalog, this input may be a simple search, an or search, a quoted search, or a compound search. Click here for more.
  2. ProductID Searchbar: Requires GoPlanogram Pro.
    Enter a ProductID here to filter the current folder to only show planograms containing that ProductID.
  3. Sort By: Sort filtered results by date Last Edited, A - Z, or Z - A.
  4. Min / Max Rack Width: Requires GoPlanogram Pro.
    Search the current folder for planograms that have between Min Width and Max Width total rack width.
  5. Tags: Requires GoPlanogram Pro.
    Search the current folder for planograms that have particular tag values.
    Tags are completely customizable by your site admin(s), so the exact names, values, and even quantity of options you see here may vary.
  6. Project Type: Requires GoPlanogram Pro.
    Search the current folder for planograms that are either Standard mode, Floorplan mode, or All.
  7. Open / Cancel: Press Open to open the currently selected planogram.
    Press Cancel to close the dialog without opening anything.

Importing and Inserting

Importing a planogram is the act of either loading or inserting a copy of a saved planogram. The original planogram may not even be owned by you -- it could have been created and saved by another one of your site's users. As long as it's shared when saved, a planogram will always be available to be imported.

Inserting is adding the contents of another planogram to your current one. A non-insert import operation will completely replace your current work. Inserting is accomplished by checking the Add to current planogram checkbox in the Import Planogram dialog. For Pro users who have floorplan projects, there are some insert operation restrictions (see below).

To import a planogram, click on the one you want from the filesystem, then click the Import button. The Import Planogram dialog contains many controls to help you find the planogram you're looking for.

  1. Main Searchbar: Search the current folder for a Planogram or Folder that matches some input.
    Like searching the catalog, this input may be a simple search, an or search, a quoted search, or a compound search. Click here for more.
  2. ProductID Searchbar: Requires GoPlanogram Pro.
    Enter a ProductID here to filter the current folder to only show planograms containing that ProductID.
  3. User Filter: Show only planograms made by a particular user, or the default, All Users, which shows all your site's users' planograms.
  4. Sort By: Sort filtered results by date Last Edited, A - Z, or Z - A.
  5. Min / Max Rack Width: Requires GoPlanogram Pro.
    Search the current folder for planograms that have between Min Width and Max Width total rack width.
  6. Tags: Requires GoPlanogram Pro.
    Search the current folder for planograms that have particular tag values.
    Tags are completely customizable by your site admin(s), so the exact names, values, and even quantity of options you see here may vary.
  7. Project Type: Requires GoPlanogram Pro.
    Search the current folder for planograms that are either Standard mode, Floorplan mode, or All.
  8. Add to current planogram: Check this box if you want to insert the contents of the currently selected planogram above your current work.
    Pro Only: Floorplan projects cannot be inserted. If your current session is in Floorplan mode, you cannot insert another planogram's contents. If you are editing the planogram of a floorplanned fixture, any inserted planogram contents will not include racks.
  9. Import / Cancel: Press Import to import / insert the currently selected planogram.
    Press Cancel to close the dialog without loading anything.

Browser Copy / Paste

This feature is not available in GoPlanogram Lite

While not strictly related to the filesystem, an alternate way to move products and fixtures between planograms is to use the Browser Copy and Browser Paste functions. Both these functions can be found in the Edit menu.

To use them, first make sure you have two tabs open and signed in to your GoPlanogram site. Both tabs must be owned by the same browser.

Then, select the contents of the planogram you want to copy, click Browser Copy, switch tabs, then click Browser Paste. The contents from the first planogram tab will now be pasted into the second tab.

The video below demonstrates this.